Reduced Acceptance Rates of Certain Incomm Gift Cards
Incident Report for CardCoins
Resolved
This incident has been resolved.
Posted Nov 13, 2023 - 21:55 UTC
Identified
We are currently experiencing reduced acceptance rates of American Express branded gift cards. If your card number begins with 377935, there may be significant delays in processing your order. We apologize for the inconvenience.
Posted Jun 23, 2023 - 14:50 UTC
This incident affected: Incomm (377935 - Amex Gift Card).